Monday 30th October 2017

Major Incident: MyTickets Apple Pay Customers

We regret to inform that we have identified an issue impacting all customers who have made a MyTickets purchase using Apple Pay between 1st October - 23rd October. Unique barcodes have not generated resulting in no Event Ticket being sent.

Customers who purchased tickets without using Apple Pay are not affected.

UPDATE 18:27 All impacted customers have been contacted by email. We are now working to get event tickets sent as soon as possible. These will be sent no later than 23:00 this evening.

UPDATE 19:00 All impacted customers should have now received tickets. We will now work to identify the root cause of the issue. If you continue to experience issues or haven't had your tickets please email hi@mychurchdown.co.uk.