Sunday 23rd July 2017

MyChurchdown MyChurchdown Outage

22/07/201: We are investigating issues affecting MyChurchdown. All Services are currently unavailable. This includes Payment Services and Support Functions. All customers attempting to make payments by Stripe are advised not to complete payments until service has returned to normal.

Update 15:06 22/07/2017 As part of our continuous improvement programme, we completed a planned upgrade earlier today (22nd July). Shortly after this a power surge resulted in a number of hardware failures which began just after 15:00. We are currently working to restore service as quickly as possible. Thankyou for your continued patience.

Update 21:00 22/07/2017 We continue to investigate issues affecting access to MyChurchdown. We have activated our backup website which is now operating via http://www.mychurchdown.org.uk.

Update 00:40 23/07/2017 All MyChurchdown services (including backup website mentioned above) will be restarted at 01:00. There will be a 10 minute outage period.

Update 01:15 23/07/2017 Following the replacement of hardware components and a service restart, we continue to experience performance related issues. We are now working with our third party providers to identify the root cause of the ongoing issues.

Update 04:45 23/07/2017 Our third party data centre are currently experiencing network issues resulting in a prolonged outage period. We will provide an update at 09:00 if not before.

Update 08:40 23/07/2017 All MyChurchdown services are back online, you may continue to experience performance related issues until 12:00.

Update 14:48 23/07/2017 All services have returned to normal. Thankyou for your continued patience.