Saturday 22nd July 2017

MyChurchdown MyChurchdown Planned Maintenance

As part of our continuous improvement programme, we will complete a network upgrade at 07:00 on Saturday 22nd July. During the upgrade, there will be an outage period of 4 hours. We appologise for any inconvenience caused.

Update 12:34 The work to upgrade MyChurchdown is now complete. Online Services are now coming back online.

Update 12:42 All MyChurchdown Services are available.